SMS Delays

Incident Report for Gazelle Telecommunications

Resolved

Around 12:45pm, we implemented a change to reduce the load of queued messages. This change positively impacted the message queue, and test messages sent now have been sent and received immediately. Our monitoring period has completed and we are resolving this incident.
Posted Jun 29, 2026 - 14:37 PDT

Investigating

We are aware of issues regarding delayed delivery of SMS messages. Our engineering team is engaged and investigating now. More information coming as soon as possible.
Posted Jun 29, 2026 - 12:14 PDT
This incident affected: Messaging.